icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.mfmyy.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

500彩票软件 www.723221.com-中国彩吧3d开奖| www.881218.cc-开私彩-| www.980794.com-附近福彩-| www.cn33.com-天下彩免费资料综| www.zi87.com-双彩网论坛论坛| www.39ma.com-手机七星彩投注网| www.4897.top-手机彩票网3a彩票| www.12894.com-举报运盛彩票| www.64414.com-网球彩票规则介绍| www.060829.com-专业购彩平台快三| www.155060.com-足彩购买时间| www.254929.com-北京5分时时彩| www.410668.com-姜山冷门足彩大赢家| www.536902.com-香港中彩网投| www.715499.com-天天中彩票彩种升级| www.855413.com-七乐彩奖金有多少| www.938666.com-北京市体彩中心地址| 网易彩票www.070wy.com| www.gd03.com-快三是合法的么| www.c25.cm-博彩彩票-| www.42pm.com-猫简笔画彩色| www.0022.bid-快三过滤软件| www.9847.com-古建彩绘图案贴纸| www.60425.com-信誉好的彩票平台| www.025933.com-澳门快3彩票| www.111407.com-679彩票下载安装| www.190639.com-福利彩票快三合法吗| www.273188.com-体育彩票公益介绍| www.400354.com-体彩大乐透历史数据| www.533920.com-七星彩前四位公式| www.616782.com-时时彩账号注册网址| www.697003.com-浙江省体彩网大乐透| www.772225.cc-买彩票什么app好| www.889926.com-nba篮球彩票推荐| www.965947.com-双色球最新彩民乐图| www.cp265.com-广西今日快三| www.ns77.com-一分钟快三计划群| www.02zt.com-彩票牛人总结的经验| www.80re.com-广州双色球彩票| www.2318.biz-彩票计划师培训| www.8564.cc-彩宝贝七星彩走势| www.64884.com-职业竞彩人心得| www.027668.com-彩票对冲套利靠谱吗| www.109964.com-足球彩票兑奖中心| www.186512.com-快三输了能上岸吗| www.266305.com-彩神app怎么下载| www.389075.com-3d杨哥说彩专栏| www.520191.com-青岛福彩郑庄养老院| www.596919.com-北京时时彩pk群| www.676225.com-体彩排五谜语| www.760929.com-腾讯分分彩规律| www.874720.com-信誉高的彩票平台| www.968637.com-乐彩vip合法吗| www.ag57.cc-熊猫网彩票-| www.sx06.com-7星彩2个号是多少| www.19eo.com-男子借钱买彩票| www.295.space-福彩双色球模拟选号| www.4294.org-鑫彩国际app| www.02412.com-至尊彩大发快3| www.72302.com-江苏老快三开奖号码| www.038053.com-爱购彩旧版本| www.128612.com-福彩种类及玩法| www.208581.com-福利彩票几期查询| www.288111.cc-高频彩合买彩票平台| www.397974.com-彩票合质是什么意思| www.525256.com-重庆福彩店-| www.611860.com-真实的体育彩票| www.687393.com-甘肃快三qq群| www.770952.com-彩之家网站首页| www.879752.com-福彩行业-| www.961432.com-老梁说彩票-| 500万彩票www.358939.com| www.ig02.com-今日彩票app| www.b66.org-火箭彩票下载| www.32df.com-云上多彩宝-| www.1010.live-福彩快开型彩票| www.7779.me-青岛体彩电话| www.27117.com-乐彩网p3专家预测| www.72277.cc-福彩3d如何定二胆| www.059412.com-辽宁省福彩12选5| www.140614.com-58彩票安卓版链接| www.220348.com-乐彩网手机版| www.295930.com-安徽福彩怏三走势图| www.369618.com-自动机选彩票平台| www.468163.com-广州福利彩票刮刮乐| www.556681.com-七乐彩走势图| www.628034.com-开门彩是什么意思| www.700385.com-福彩3b字谜僵局| www.781289.com-酷彩吧app怎么样| www.861587.com-体彩开奖助手| www.929931.com-福彩3d九宫八卦图| www.987565.com-河南幸运彩技巧跑马| www.cp3522.com-福建快三中奖助手| www.nu57.com-彩票赌博输钱| www.48zk.com-天天赢彩票平台注册| www.887.xyz-快三倍投8倍是多少| www.5214.biz-中国体彩七星彩奖历| www.07542.com-500彩票人工计划| www.54674.com-微信申请彩金| www.99697.cc-河内五分彩中奖规则| www.066971.com-凤凰彩票可信度| www.134722.com-解福彩臧机图| www.199284.com-广西快三电视走势图| www.272474.com-极速3d彩票走势图| www.510768.com-夸人厉害的彩虹屁| www.580169.com-慧扑彩彩票网| www.652324.com-民勤谁中彩票| www.808553.com-乐慱彩票app| www.879822.com-赢彩网真的能赚钱吗| www.975788.com-北京福彩电投小助手| www.om1.com-手机app彩票停售| www.po48.com-胜负彩500彩票| www.8fg.com-网上彩票破解方法| www.63jy.com-彩金卖多少钱一克| www.0410.xyz-排列三缩水彩吧工具| www.8272.org-南昌彩民中奖| www.28328.cc-天下争霸彩票合法吗| www.70068.cc-体彩太湖三字诀| www.050407.com-天天买彩票下载| www.129740.com-彩票中奖收税| www.199177.com-福利彩票3d开机号| www.268800.com-台湾快三查询| www.369845.com-足彩封盘-| www.455633.com-区块链彩票股票| www.539784.com-彩票和值怎么买| www.639784.com-天天悦彩-| www.721553.com-七星彩内部精准码| www.790820.com-买彩票选号技巧| www.862084.com-牛彩网七乐彩预测| www.923351.com-彩票店怎么都关门了| www.977733.com-体彩世界杯竞猜网| www.dz19.com-上海福彩选四规则| www.ue00.com-大华彩票-| www.65.me-皇樂彩票合法吗| www.63bu.com-体育彩票奖励| www.0014.pw-彩票双色球几位数| www.8278.top-恒彩2-| www.25753.com-彩神提前预支助手| www.64866.com-体彩店怎么找客户| www.033071.com-鹤壁彩票-| www.102696.com-时时彩平台信誉| www.163904.com-买彩票值得买吗| www.269860.com-9彩计划-| www.353032.com-药京彩怎么使用| www.423966.com-彩乐乐排三杀号| www.516493.com-彩票47-| www.578233.com-东北快三下载地址| www.643636.com-分分彩预测-| www.819290.com-亳州天价彩礼事件| www.883651.com-彩排什么-| www.965643.com-一分钟彩票网址| 万历彩票www.77114g.com| www.em05.com-快彩拉人有什么原因| www.tv29.com-4k彩票-| www.7cl.com-武汉做体彩的公司| www.53zd.com-鼎峰彩票36136| www.636.mobi-彩18平台-| www.3865.wang-贵州快三一共几期| www.8898.cc-竞彩足球截止时间| www.76755.cc-体彩任选九开奖时间| www.021474.com-7k彩票566-| www.082797.com-玩五分快三靠谱吗| www.14ux.com-体彩开奖18143| www.87xk.com-临夏市福利彩票|